Leave feedback
  • Question

    CCE16 Archive Server settings

Enter a new topic
  • Bipin Mishra Bipin Mishra
    0 likes 995 views

    Hi,

    I want to archive my documents in content server. I am using content server filter in design center. But in control center I am unable to see ELS Archive repository. I have already registered StreamServe application in Opentext Administration Client in ELS an done with all my setting.

    Just not able to understand in which repository I will use for Archive Server.

    Regards

    Bipin

    Wednesday 30 November, 2016
  • Best Answer
    Ugis Godmanis Ugis Godmanis
    0 likes

    Hi,

    In CCE16 you don't need Enterprise Library for archiving to CS anymore. You simply have to use CS filter and specify connection directly to CS (it is using REST API for archiving). Also in filter you define all settings such as where you want to store files, name, format, etc.

    In documentation it is stated that CCE16 only supports CS16, but CS10.5 also has REST API module (must be installed seperately), so theoretically it might work with 10.5.

    Ugis

    Thursday 08 December, 2016
  • Ramya Pelluri Ramya Pelluri
    0 likes

    Hi Ugis,

    Is there any detailed documentation for the Content Server filter.  I went through the Project Configuration Guide but I keep getting the error:

    0 [ContentServerFilter] Unable to call rest api. Response code [400: ]
    0 [ContentServerFilter] Error communicating with Content Server

    I have set:

    Content Server URL as http://localhost/OTCS/cs.exe

    CS Virtual Path as http://localhost/OTCS/cs.exe/api/v1/auth

    Please help.

    Thanks,

    Ramya

    Tuesday 01 August, 2017
  • Ugis Godmanis Ugis Godmanis
    0 likes

    Hi,

    There is not much documentation about CS filter, you can try checking out CCE16 project configuration guide and filters section.

    Regards your setup, i think that URL to CS REST API is not correct, it should end with /api/v1 or just /api.

    /api/v1/auth is used just for authentication but I think that Streamserve expects an api root.

    Ugis

    Wednesday 02 August, 2017
  • Ramya Pelluri Ramya Pelluri
    0 likes

    Thanks Ugis,

    I have tried with http://localhost:80/OTCS/cs.exe/api but still same issue:

     0 [ContentServerFilter] Unable to call rest api. Response code [404: ].

    Ramya

    Wednesday 02 August, 2017
  • Ramya Pelluri Ramya Pelluri
    0 likes

    I have made the following changes:

    Content Server URL as http://localhost

    CS Virtual Path as /OTCS/cs.exe/api/v1/nodes/

    Got the error: Unable to call rest api. Response code [401: ]

    It is the authentication failed error.

    Any clue?

    Wednesday 02 August, 2017
  • Ugis Godmanis Ugis Godmanis
    0 likes

    Hi,

    CS URL - just the protocol, host and port, e.g. http://localhost
    CS Virtual path - everything that comes after host and points to rest API, e.g. otcs/cs.exe/api/v1
    Authentication profile - specify username and password that will be used to connect to CS, e.g. Admin

    You should have OTDS set up as well

    I think OT had a special installer that installed/configured everything in one go (version 16). You could check that out + documentation to understand what needs to be configured for CS/OTDS integration and how it is done.

    Ugis

    Thursday 03 August, 2017
  • Ramya Pelluri Ramya Pelluri
    0 likes

    Thanks Ugis,

    OTDS is configured, should I create a Content Server connection profile to the tenant? If yes, where can I find the XML Connection Profile file for the Content Server.

    Ramya

    Thursday 03 August, 2017
  • Vikas Rathaur Vikas Rathaur
    0 likes

    Hi Ramya,

    I also faced the same issue but if any ECM guy working with you the please show him/her this links, they should provide the right links to u and try access link CS link in ur browser its hould have worked.

    Regards

    Vikas

    Thursday 10 August, 2017

 

Latest from the blogs

Read more