Leave feedback
  • Discussion

    Collector from Post Processor

Enter a new topic
  • Christofer Lindqvist Christofer Lindqvist StreamServe Employee
    0 likes 3183 views

    Hi,

    Has anyone set up Collector functionality from the Post Processor?

    Im trying but im having some trouble.

    First it seems like only the first document is created as an instance in the Collector (i use documnet output mode to pdf as out connector). The other 3 documents in the job disappears.

    Second, i cant seem to get any variables to work as values for the metadata, to be searchable in the Collector. I have tried both metadata values & stored variables.

    Regards,

    Christofer

    Monday 18 January, 2010
  • Christofer Lindqvist Christofer Lindqvist StreamServe Employee
    0 likes

    To answer my own question.

    Install the latest hotfix for SP3 (329). This will fix the problem.

    From the PDF for the hotfix:

    "A Post-processor Project did not store all documents in Collector. Only the
    first document was stored. The reason was that the Document Broker did
    not support archiving when running in Document mode."

    /Christofer

    Monday 18 January, 2010
  • Hanna Widenberg-Jansson Hanna Widenberg-Jansson StreamServe Employee
    0 likes

    Hello Christofer!

    Did the latest hotfix also solve the problem with not being able to use metadata or stored variables as collector metadata? On what runtime level do you set the stored variables?

    Thanks!

    /Hanna

    Monday 18 January, 2010
  • Mikael Lohman Mikael Lohman StreamServe Employee
    0 likes

    I got some more information from Support. they wrote:

    "you can, in certain cases, run in document mode when using Post Processing but if you run in Job mode, you can not archive.

    I'm afraid the only solution we offer (for the time being but this is being looked at by product management) is to process the data twice, once in document mode when you want to archive and once in Job mode when you want to create the PDF files. I realize there are some drawbacks with this if you do use enveloping (since the documents will not be split the same way) but I'm afriad that is the best I can do for the time being."

    //Mikael

    From: Widenberg-Jansson, Hanna
    Posted: Wednesday, January 21, 2009 5:53 PM
    Subject: Collector from Post Processor

    Hello Christofer!

    Did the latest hotfix also solve the problem with not being able to use metadata or stored variables as collector metadata? On what runtime level do you set the stored variables?

    Thanks!

    /Hanna

    From: Lindqvist, Christofer
    Posted: Thursday, December 11, 2008 3:09 PM
    Subject: Collector from Post Processor

    To answer my own question.

    Install the latest hotfix for SP3 (329). This will fix the problem.

    From the PDF for the hotfix:

    "A Post-processor Project did not store all documents in Collector. Only the
    first document was stored. The reason was that the Document Broker did
    not support archiving when running in Document mode."

    /Christofer

    From: Lindqvist, Christofer
    Posted: Thursday, December 11, 2008 1:40 PM
    Subject: Collector from Post Processor

    Hi,

    Has anyone set up Collector functionality from the Post Processor?

    Im trying but im having some trouble.

    First it seems like only the first document is created as an instance in the Collector (i use documnet output mode to pdf as out connector). The other 3 documents in the job disappears.

    Second, i cant seem to get any variables to work as values for the metadata, to be searchable in the Collector. I have tried both metadata values & stored variables.

    Regards,

    Christofer

    Monday 18 January, 2010
  • Andreas Persson Andreas Persson OpenText Employee StreamServe Employee
    0 likes

    I have the same problem now. BUT i am running in Job mode.
    to create my PDF and PS file I run a ppq that collects all the data. One output file contains PP-documents form more than one PP-Job. therefore i think i need to ru in job mode? Hence, during one job i create many files. I manage to archive the first document but without any metadata. is it really the case that we can not do this?

    //Andreas

    Monday 18 January, 2010
  • Andreas Persson Andreas Persson OpenText Employee StreamServe Employee
    0 likes

    I am running SP4 hotfix 495.

    Monday 18 January, 2010
  • Martin Vogel Martin Vogel StreamServe Employee
    0 likes

    Hi Andreas,

    Are you sure you fill metadata in the right time? Do not forget that if using SetDestPast on Document Begin script,  you have no access to stored variables of previous document any longer!

    Martin

    Monday 18 January, 2010
  • Bjorn Sundstrom Bjorn Sundstrom StreamServe Employee
    0 likes

    We currently have a problem with variable-based metadata when archiving Post-processor output. The variables' original values are restored by the PP before they are archived. If the original values were null, you get no metadata.

    A fix is being investigated.

    /Björn

    Monday 18 January, 2010

 

Latest from the blogs