Leave feedback
  • Question

    quealias - problems with printing from M3 via streamserve

Enter a new topic
  • Kai-Frode Magnussen Kai-Frode Magnussen
    0 likes 4482 views

    We are setting up a new persuasion server for printing from M3, and are upgrading from 4.1.2, to 5.5. It is up and running to the point that we have setup some documents that we can output by mail. But when I try printing from M3 I get this error message:

    “Output connector not found (outconnector, path):PCL             \\NO-FLO-18-10\no-flo-71-54, quealias”

    It is setup like this in my project.

    1. I have a output connector called PCL

    On this connector I have the property set to % (see screenshot in attached file)

    2. In the Runtime Event Settings, I have selected “Select automatically”, and "Agent driven" (see screenshot in attached file)

    3. The quealias is in my resource set, (which I also find in the management gateway  after I deploy it (\ManagementGateway\1.0\root\applications\...\data\tables)) and the content looks like this:

    NOFLO7012                       PCL                        \\NO-FLO-18-10\NO-FLO-70-12

    NOFLO7014                       PCL                        \\NO-FLO-18-10\NO-FLO-70-14

    NOFLO7015                       PCL                        \\NO-FLO-18-10\NO-FLO-70-15

     

    (Email works as it should though.)

    (Persuasion version 5.5.0 build 1450)

    Can anyone see what I have done wrong?

     

    Tuesday 14 August, 2012
  • Best Answer
    Kai-Frode Magnussen Kai-Frode Magnussen
    0 likes

    I couldn't use a local account for the service in control center. When I changed this to a user with proper access rights the printouts finally appeared...

    Wednesday 15 August, 2012
  • Kai-Frode Magnussen Kai-Frode Magnussen
    0 likes

    It seems as I was a bit too quick in thinking that the problem is solved. Now I am back to nothing printing.

    When I send a printout first this line appears in the log

    0816 180759 (1111) 0 Output connector not found (outconnector, path):PCL \\NO-FLO-18-10\NO-FLO-71-54, quealias

    then a bit further down when the actual printing is supposed to take place.

    0816 180759 (1014) 1 Missing or incomplete alias map for  NOFLO7154, quealias

    Any ideas as to what is wrong?

    Thursday 16 August, 2012
  • Vyv Lomax Vyv Lomax Administrator
    0 likes

    Have you tried copying the quealias file into the working directory?

    Try encapsulating the \\Server\Printer with quotes. e.g. "\\Server\Printer"

    Have you tried to log the alias key?

    Are you using the agent or the AgentDriver() function?

    Just some late night thoughts.....

    Thursday 16 August, 2012
  • Kai-Frode Magnussen Kai-Frode Magnussen
    0 likes

    Thanks a lot for you late night thoughts. I am a bit unsure on some of these details.

    1. by working directory. what do you mean? Is this the structure where the deployment file ends up? The quealias ends up here after export/deployment

    D:\Lawson\ManagementGateway\1.0\root\applications\EWOS_Norway\data\ta bles.

    But the quealias file itself is found in the resource set. The physical location on this file is just a normal windows folder. Is it this file that should be placed somewhere

    2. I have tried encapsulation the server/printer with quotes without any luck. I guess that is mainly if the printername/queue has open spaces?

    3. what do you mean by log the alias key? and how do I do it?

    4. When it comes to agent/agent driver I am not sure. I use (they are ticked on) the "agent driven" and the "select automatically" in the runtime event settings, and on the event, agent settings, input type is set to "Movex".

    Thanks again. Hoping for more late night thougts :-)

    Friday 17 August, 2012
  • Kai-Frode Magnussen Kai-Frode Magnussen
    0 likes

    A few more details from a confused streamserveruser

    I see from control center that my working directory is D:\Lawson\ManagementGateway\1.0\root\applications\EWOS_Norway\Producti on.

    I tried to put the quealias.dcres (and the quealias) here, and then use this file in the resource set. It didn't work. And I do not quite see why it should, as I thought it was the

    D:\Lawson\ManagementGateway\1.0\root\applications\EWOS_Norway\data\ta bles\quealias file that is read into control center?

    Friday 17 August, 2012
  • Martin Hale Martin Hale
    0 likes

    I don't think this is actually the cause but I noticed Vyv mentioned about the quealias file being in the working directory. The following code is taken from the AgentDriver function:

    $printer=$mvx_DEVICEARR[$i]; $outpath   = getsubst(".\QUEALIAS",$printer,1); $que       = getsubst(".\QUEALIAS",$printer,0);

    If you note the path to the quealias file, this should be something more like "../data/XXXXX" as resources are now deployed a level higher up the hierarchy. Obviously this wouldn't solve your issue as you're getting a value returned.

    In your case it looks like the result is actually a combination of 2 columns from the quealias file. The log suggests it is taking "PCL" and "\\NO-FLO-18-10\NO-FLO-71-54" as being the server address value. This may be part of the problem.

    Wednesday 22 August, 2012
  • Andrew Michnik Andrew Michnik StreamServe Employee
    0 likes

    If the AgentDriver tick box is ticked the function itself is not used.

    I would have thought access rites would be the problem

    Wednesday 22 August, 2012
  • Kai-Frode Magnussen Kai-Frode Magnussen
    0 likes

    Thank you for your reply Martin and Andrew

    I do not have a clear enough understanding of the difference between what Viv referred to as the agent vs the Agentdriver() function, so I have some questions about this;

    1. What is the difference between the agent and the AgentDriver() function?

    2. As far as I can see there are no agentdriver()in my resourceset. I guess this means that we are using the agent? As you can see from the attachment to my first post, the Agent Driven tick box is ticked.

    3. Is using the agentdriver() function a choice that has to be made? If so, what are the advantages/disadvantages?


    The reason why I ask is that the project I have problem with, is running smoothly and printing on 4.1.2 today, and there are no agentdriver() function in the MOMStandard C2.0.cml function that we are using.
    (The project consists of about 10 different M3printouts /streamserveprojects, that are modified with layouts, scripting and so on based on standard lawson docs.)


    I see that in our most recent project (setup by Lawson a month ago) for printing all of our standard unmodified Lawson documents,  there is a function called "Lawson V2.2.fcn" that do have the agentdriver()function.

    It looks slightly different from the one that you are refering to, Martin, as there are no ".\" in the path to quealias.

    $printer=$mvx_DEVICEARR[$i];
    $outpath   = getsubst("QUEALIAS",$printer,1);
    $que       = getsubst("QUEALIAS",$printer,0);

    But this project also has ticked the "select automatically" and the "agent driven" choices in the runtime event settings.

    4. Does this mean that standard Lawson is not using the agentdriver() function.

    Wednesday 22 August, 2012
  • Vyv Lomax Vyv Lomax Administrator
    0 likes

    Is there a tab between KEY and VALUE in your quealias file?

    The quealias.dcres file is not used by the server. This file is just a Design Center file.

    The working directory is the application and physical platform / layer combo. I belive it is in your case:

    D:\Lawson\ManagementGateway\1.0\root\applications\EWOS_Norway\Produc tion

    Traditionally I have always had the quealias file in the working directory (from 3.X, 4.X days) and it is a hard habbit to kick. I believe that the quealias file would work in both data\tables and in wd for Persuasion.

    I have a working quealias file with MOM here - looks like there is no PCL column like you have:

    PRTPR \\COMPANY\HP5000MGA
    PRTRE \\COMPABY\HP2300MGA

    How far have you got? Maybe solved this already?

    Wednesday 22 August, 2012
  • Vyv Lomax Vyv Lomax Administrator
    1 likes

    Does your quealias file have a Multicolumn header?

    Wednesday 22 August, 2012
Next