Leave feedback
  • Question

    Control Center connection time out

Enter a new topic
  • Shashi Prakash Shashi Prakash
    1 likes 3010 views

    I am trying to install and administer SP5 EP1 version. My architecture is like one below:

    Comp1(Windows): Control Center

    Comp2(Solaris): StreamServer

    Comp3(Solaris): Enterprise and Runtime Repository

    I have installed Framework and StreamServer on Comp2 using command "./setup".

    Now I try to connect Control Center from Comp1 to MGW on Comp2. I use port forwarding through tunnelier to connect to MGW on Comp2.

    Control Center prompts to Change MGW password for the first time.

    It then prompts SER configuration. Configuration is accepted.

    I then generate SER scripts and asks DBA to create SER.

    MGW makes entry to the nodes table in the SER. 

    Once SER is created and node entry is made to the SER Nodes table.

    Now when I try connecting the site it times out every time.

    I then tried manually create Application Domain using command line. 

    I have asked DBA to create Runtime Repository using script. I have then created StreamServer Application, Created Service and deployed export using command line.

    I have then started the application service. It shows like "Service is Started". When I run "isrunning" command it shows "Service is not started". No logs are created. I am not able to figure out where the issue is. No errors are thrown on the terminal.

    For some reasons Control Center is still throwing time out error when it tries to fetch domain information.

    Monday 20 February, 2012
  • Best Answer
    David Shih David Shih StreamServe Employee
    1 likes

    Control Center has problems with proxy servers and SSH port tunnels.

    The login from Control Center to Mangement Gateway actually uses two TCP connections, which is why it's having trouble with your SSH tunnel:

    • Comp1->Comp2 (proxied via Comp1 TCP:22 to Comp2 TCP:28000) - establish connection
    • Comp2->Comp1 - send reply back to Comp2 on TCP:28000
    • Comp1->Comp2 on TCP:28000... drops

    The second connection is being dropped because Comp1 is receiving a URI that says to use Comp2:28000, instead of the proxied SSL connection that it started with.

    Monday 20 February, 2012
  • Shashi Prakash Shashi Prakash
    1 likes

    Thanks David. Now I know why Control center was behaving like that.

    I have found a workaround to connect Control Center over tunnel.

    1) I have used same ipport for tunnel mapping. (localhost:ipport to nodehost:ipport)

    2) I have tweaked hosts file on comp1. I have added a new entry

    127.0.0.1 nodehost

    Now the third outbound connection again goes through localhost:ipport and is forwarded to nodehost:ipport.

    This way I am able to connect Control Center Site.

    Now I can see the logs while starting the Apllication Service. Issue seems to be in the territory file.

    I can now debug it and moreover create a fresh application domain from Control Center. 

    Thank you!

    Tuesday 21 February, 2012

 

Latest from the blogs

Read more